Mapped drives do not connect after wake from low power state

Surveyor 5.x

Knowledge Base

This article describes why this issue occurs and lists several procedures for resolving it.

Symptoms

When a client computer tries to wake from a low power state, mapped drives are not re-connected or do not display.

Conditions

The conditions that cause this issue are the same as for Symptoms indicating failed GPO process occur when waking PC device.

Cause

It appears that the network card is not fully initialized when the user logs on to Windows.

Solution

Microsoft has addressed the problem in subsequent Windows versions. It will not be addressed in Windows XP.

For Windows XP, the following procedures have resolved the issue. Solution 1 applies client systems that have typically been in a standby state for at least 6 hours (usually over night).

  • Solution 1: Wake client systems up prior to users arriving in the office.

This set of solutions applies to client systems during the day.

  • Solution 2: Microsoft hotfix described in KB article 940648
  • Solution 3: Enable a "wait for network during logon" Group Policy setting.
  • Solution 4: For Cisco switch-based networks, enable PortFast for computer switch ports.
  • Solution 5: For Windows 2008 Servers with XP clients

Solution 1: Wake client systems up prior to users arriving in the office in the morning

You wake client systems by scheduling a Wake in the policy used by the clients. The client systems must then be awake and idle for at least a minute prior to users interacting with the computer.

Note: Customers report that this solution only applies to cases where the system has been in standby for over 6 hours.

Wake clients on a schedule in Surveyor 5.x

Wake devices on a schedule in Surveyor 6.x

Solution 2: Microsoft hotfix

This hotfix is described in KB article 940648.

Solution 3: Enable a "wait for network during logon" Group Policy setting

In the Group Policy Object Editor (Gpedit.msc), in Administrative Templates\System\Logon, enable the policy setting Always wait for the network at computer startup and logon.

The corresponding registry setting is HKLM\Software\Policies\Microsoft\WindowsNT\CurrentVersion\Winlogon!SyncForegroundPolicy

Background information

From Microsoft TechNet:

All versions of Windows XP Professional provide a fast logon optimization feature. By default, computers with these operating systems do not wait for the network to start when they boot up. After logon, policy is processed in the background once the network is available. This means that at logon and startup, the computer will continue to use the earlier [cached] policy settings. Therefore, for settings that can only be applied at boot or logon (such as software installation and folder redirection) more than one logon can be required by the user after the initial change is made to the GPO.

To work around the issue of drives not mapping when a computer wakes from a low-power state, you create a Group Policy setting that changes this default "fast logon" behavior.

For more information and to determine whether multiple logons are required, see Group Policy processing and precedence on Microsoft TechNet.

Solution 4: For Cisco switch-based networks, enable PortFast

For DHCP errors, see Cisco tech note 10553: Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays

Enable PortFast only on leaf nodes (computers or phones). Enabling it on other types of connection (trunk, switch to switch, and so on) could result in a routing loop. From the Cisco tech note:

Caution:

Never use the PortFast feature on switch ports that connect to other switches, hubs, or routers. These connections can cause physical loops, and spanning tree must go through the full initialization procedure in these situations. A spanning tree loop can bring your network down. If you turn on PortFast for a port that is part of a physical loop, there can be a window of time when packets are continuously forwarded (and can even multiply) in such a way that the network cannot recover.

Additional notes

Cisco added the PortFast (fast-start) feature. With this feature, the STP (Spanning Tree Protocol) for the port assumes that the port is not part of a loop. It moves directly to the forwarding state, skipping the blocking, listening, or learning states. Enabling PortFast does not disable the STP. Rather it makes the STP skip a few initial steps (unnecessary steps under the circumstances) on the selected port.

Solution 5: For Windows 2008 Servers with XP clients

Possible Cause #1: Problematic client doesn't reconnect to the target share at logon

Please follow the steps to re-configure the mapped driver on the client and then check if the issue will re-occur.

  1. Open My Computer.
  2. Click Tools, and then select Map Network Driver.
  3. Enter the \\ipaddressofserver\sharename to give the path of the share.
  4. Select Reconnect at logon. The drive is mapped.
  5. Double-click the drive name to check mapping.

Possible Cause #2: Antivirus software or Windows Firewall may block the SMB protocol on clients

Please check if there is any Antivirus software and the Windows Firewall is enabled on the problematic client. If so, please disable them to check if the issue can be resolved.

Possible Cause #3: Fast Logon Optimization is enabled on the clients

The fast logon feature may affect the display and drive letter assignment of a mapped network drive. As a result, the drive may have been mapped; however, the user on client cannot see it in Windows Explorer. The user may recognize it as a failed network drive mapping. This is the reason why we usually suggest you to disable fast logon on the clients via a GPO, and please check if the mapped network drive will be occur under this circumstance.

Please also configure the following group policy setting to disable Fast Logon Optimization to see if the issue still exists on the problematic clients.

Computer Configuration\Administrative Templates\System\Logon\Always wait for the network at computer startup and logon

When this policy is enabled, a Windows XP client behaves in the same manner as a Windows 2000 client at both system startup and at user logon.
Please note: As this is a computer configuration, please run "Gpupdate /force" and then reboot the problematic clients to make it take into effect.

For more information about Fast Logon Optimization feature, please see the following KB article: 305293 Description of the Windows XP Professional Fast Logon Optimization feature.

If the issue still exists on the problematic clients after following the previous steps in this solution, please also try adding the following registry subkey on the problematic client to verify it works.

  1. Click Start, click Run, type REGEDIT, and then click OK.
  2. Locate and click the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\NetCache
  3. Click Edit, point to New, and then click DWORD Value.
  4. Type SilentForcedAutoReconnect , and then press ENTER to name the value.
  5. Double-click SilentForcedAutoReconnect.
  6. In the Value data box, type 1, and then click OK.

Please contact Verdiem Support with concerns or further questions.

Additional information

Additional strategies have included disabling media sensing, which worked for one of our larger customers. For information, see the following articles from Microsoft:

Applies to

Product

  • All Verdiem Surveyor versions

Operating system

  • Windows XP Professional