System clock is incorrect when client wakes

Surveyor 5.x

Knowledge Base

Note: This issue appears to correct itself if you wake the machine 3+ minutes before a user logs into the system. Customers have found that waking the systems from standby prior to user interacting with the system has resolved the issue.

This article refers to two Microsoft hotfixes that can solve this issue on Windows XP computers.

Symptoms

When a client wakes from a low power state, the Windows time is incorrect.

Conditions

The conditions that cause this issue are the same as for Symptoms indicating failed GPO process occur when waking PC device.

Cause

It appears that the network is not fully initialized when the user logs on to Windows.

Solution

Microsoft has addressed the problem in subsequent Windows versions. It will not be addressed in Windows XP.

For Windows XP, potential solutions include the following hotfixes created by Microsoft.

Additional information

Neither solution seems to be related to a specific environment. But the key .dll files that control the system clock are updated, so applying one of them is a recommended first step in solving this issue.

See also

Applies to

Product

  • All Verdiem SURVEYOR versions

Operating system

  • Windows XP Professional